Symptom
Sales orders created via the web service are still in status In Preparation even though in the SOAP Request XML which created the sales order ,the tag <ReleaseCustomerRequest> is set to true.
Environment
SAP Business ByDesign
Reproducing the Issue
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Go to work center Sales Orders.
- Go to view Sales Orders.
- Select the Sales Order XYZ with status In Preparation. (XYZ represents the Sales Order ID created via web service)
Cause
The tag <ReleaseCustomerRequest> only controls the technical status and is not related to the actual releasing of a sales order (Submit->Release order on the UI) which changes the status of the order from In Preparation to Open which is controlled via the fine tuning question.
You have enabled the question "Would you like your employees to control the release of sales orders that originate from an E-Shop in order to initiate order processing? " by setting it as YES, and hence the sales order will be in "In preparation" status.
Resolution
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Go to the Business Configuration work center.
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Select the Implementation Projcets view.
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Select the respective implementation project.
- Click on the Edit Project Scope button.
- In Scoping, go to the section Questions.
- Select the following path Sales -> Selling Products and Services -> E-Selling.
- In the section Questions: Sales Order Release Procedures the following question is set to No:
Would you like your employees to control the release of sales orders that originate from an E-Shop in order to initiate order processing?
See Also
Keywords
ReleaseCustomerRequest; web service; Origin; Internet; , KBA , web service , internet , releasecustomerrequest , AP-SLO-SO , Sales Order , Problem