SAP Knowledge Base Article - Public

2626400 - Cannot Remove Mandatory Flag on the Company Field in Lead Quick Create

Symptom

The mandatory flag on the Company field in Lead Quick Create stays active even if removed via Adaptation mode.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Sales work center
  2. Go to the Leads view
  3. Enter Adaptation mode
  4. Click New to open the Lead QC
  5. Select Lead Information, -> select the 'Company' field

Result: the 'Set as Mandatory' checkbox is not set. Still, the field shows and acts as mandatory.

Cause

This is the expected system behaviour. Currently, it is not possible to set the Company field as not mandatory in Lead's Quick Create. The Company field is only used for leads that do not have an existing Account, so when/if this lead is converted to an Opportunity, a new Account is created with the information maintained in the Company field.

Resolution

This would be considered a new feature request You can submit your idea here:

https://influence.sap.com/sap/ino/#/campaign/1868

Keywords

Lead QC, mandatory, Company, Adaptation , KBA , mandatory flag , lead quick create , company field , LOD-CRM-LM , Lead Management , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions