SAP Knowledge Base Article - Public

2627579 - 'Account of payer/payee ABC with requested ID XXX is not valid' Error Message in Outgoing Bank Transfer

Symptom

You receive an error message while creating a New Outgoing Bank Transfer:

'Account of payer/payee ABC with requested ID XXX is not valid'

ABC means the payee (supplier) ID.

XXX means the payee bank.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to Liquidity Management work center.
  2. Go to Common Tasks view > New Outgoing Bank Transfer.
  3. Enter all the mandatory data.

System throws error message: 'Account of payer/payee ABC with requested ID XXX is not valid'

Cause

The reason for the error message is that the payee (supplier) bank account is not valid at the Outgoing Bank Transfer Document Date.

For example the Supplier Bank Account is valid as of 02.03.2018, but the Document Date you have entered is 01.03.2018.

Resolution

There are two options to overcome the error message:

1) Change the Outgoing Bank Transfer Document Date to a date equal or after the Supplier Bank Account Valid From date.

2) Change the Supplier Bank Account Valid From date to a date equal or before the Outgoing Bank Transfer Document Date.

For the second option, the steps to be followed are:

  1. Go to Supplier Base work center.
  2. Go to Suppliers view.
  3. Search for the respective supplier.
  4. Select the row of the supplier and click Edit > Financial Data.
  5. Go to Bank Data tab.
  6. On top, right-hand side, click the user profile picture > Start Personalization Mode.
  7. Expand Unnamed Table UI Element.
  8. Tick Valid From to make it Visible (the Valid From field is hidden by default so you need to make it visible).
  9. Click Save.

Now you can change the Bank Data validity.

Keywords

outgoing bank transfer; account not valid; , KBA , fop_paym_order:311 , outgoing bank transfer , account not valid , SRD-FIN-CLM , Cash and Liquity Managment , How To

Product

SAP Business ByDesign all versions