Symptom
While converting a Lead, an Account which has no relation or is restricted to the user is shown in the Duplicate Check step.
Environment
SAP Cloud for Customer
Reproducing the Issue
-
Go to the Sales work center
- Navigate to the Leads view
- Open the Lead ABC (Where ABC represents the Lead ID)
- Click on Actions → Convert to Account
- In the Duplicate Check step, you can see accounts that are not related to the user, or which are restricted for the user.
Cause
In the duplicate check phase, all accounts - both related and unrelated to the user are displayed.
Resolution
This system behavior is an expected standard behavior to ensure that redundant account data is not created in the system.
♦ For example, if the access restriction is applied for the duplicate check step and possible account information is hidden from view of the user, there can be a possible scenario where the end user might try to create a new contact or customer/account with the same data.
♦ At this point, system would thrown an error/warning message and indicate the presence of the data already being present within the system. This would lead to confusion for the end user, since, he would not be aware of the such data being already present in the system.
♦ To avoid this situation, system behavior is designed in such a way to display the presence of possible account data during the duplicate check step, whether restricted, related or unrelated to the end user.
♦ It is important to note that, the access restriction set up on the account for the user, would also be applicable as per the restriction rules configured, since the end user would not be able to navigate to the particular account and view the account information that he is not supposed to be able to see.
Keywords
duplicate check, duplicate check account, restricted account , KBA , convert opportunity , account , duplicate check , LOD-CRM-LM , Lead Management , LOD-CRM-ACC , Account , LOD-CRM-OPP , Opportunity Management , LOD-CRM-CON , Contact , Problem