SAP Knowledge Base Article - Public

2628098 - 'Document Creation Notification' Is Not Received After Form Launch for Performance Management or 360 Multi-Rater

Symptom

After successfully launching performance/360 multi-rater forms, employees did not receive a Document Creation Notification.

**Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental**

Environment

  • SAP SuccessFactors Performance Management
  • SAP SuccessFactors 360 Reviews
  • SAP SuccessFactors HXM Suite

Reproducing the Issue

  1. Go to Admin Center > Launch Forms
  2. Complete all steps to launch forms to employees
  3. Employees have forms in their Inbox, but did not receive the Document Creation Notification

Cause

  • A job info change business rule is configured and the first step of the route map has the E (subject) role
  • The Document Creation Notification is not enabled
  • An email address is not populated in the UDF file
  • The Sender and Recipient are the same
  • The Send email notifications to form recipients option was not enabled when forms were launched to the employees
  • Invalid tokens are used in the email subject or email body

Resolution

A job info change business rule is configured and the first step of the route map has the E (subject) role

When a business rule is configured to launch a form based on a job information change, the system has difficulty determining the originator of the form because there are multiple methods in which a job information change can be triggered. If the first step of a route map has only the E (subject) role, the system will interpret the subject as the originator and the system will not trigger this email notification.

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The Document Creation Notification is not enabled

Please follow the steps in Managing User Information - Configuring E-Mail Notifications to enable and configure the email notification.

Ensure the email address is populated in the UDF file

Please follow the steps in Managing User Information - Exporting User Data and add the email address.

The Sender and Recipient are the same

This is expected behavior. The sender needs to be different from the recipient and is mentioned in Implementing and Managing Performance Management - Email Notifications.

The Send email notifications to form recipients option was not enabled when forms were launched to the employees

Follow the steps from Implementing and Managing Performance Management - Launching Forms. Step 6 contains the below option:

form_launch_sanitized.png

Invalid tokens are used in the email subject or email body

The only supported email tokens are in Implementing and Managing Performance Management - Email Notifications. Any unsupported tokens will need to be removed for the notification to be sent.

See Also

Keywords

email, e-mail, launch forms, send email notifications to form recipients, document, creation, notification, employee, not received, triggered, SF, Success Factors, emails, missing, lost , KBA , csg_q , LOD-SF-PM-EML , Emails and Notifications , LOD-SF-PLT-NOT , Email Notifications , LOD-SF-MTR-EML , Emails and Notifications , Problem

Product

SAP SuccessFactors HCM suite all versions ; SAP SuccessFactors Performance & Goals all versions