SAP Knowledge Base Article - Public

2628108 - Sales Unit Determination in Opportunites Does Not Work Consistently

Symptom

You fine-tuned the opportunity parties Sales Unit and Sales Organization to be derived from the customer's Sales Data.

When you change the Sales Organization in a document manually, in some instances the Sales Unit data is not changed according to the Sales Organization.

Environment

SAP Hybris Cloud for Customer

Reproducing the Issue

  1. Go to the Customers work center.
  2. Go to the Accounts view.
  3. Open Account ABC (ABC represents the account name).
  4. Go to the Opportunities facet.
  5. Click New.
  6. The Sales Organization and the Sales Unit are correctly determined as per the fine tuning maintained in your Business Configuration.
  7. Change the Sales Organization in the Quick Create to XYZ (XYZ represents a different Sales Organization to the previous entry).

Result: The Sales Unit is correctly changed to the Sales Unit of the Sales Organization XYZ.

  1. Go to the Customer work center.
  2. Go to the Accounts view.
  3. Open Account DEF.
  4. Go to the Opportunities facet.
  5. Click New.
  6. The Sales Organization and the Sales Unit are correctly determined as per the fine tuning maintained in your Business Configuration.
  7. Change the Sales Organization in the Quick Create to UVW (UVW represents a different Sales Organization to the previous entries).

Result: The Sales Unit is not changed to the Sales Unit of the Sales Organization UVW.

Cause

When you change the Sales Data manually in the document, the fine tuning determination stops.

The party determination is created once for the document as per default. After a manual change the system ignores the manual entry of the Sales Organization. Instead, the Sales Unit of the given Distribution Channel and Division is derived.

In consequence, the Sales Data for Distribution Channels with only one Sales Organization behaves differently than Sales Data for Distribution Channels with multiple Sales Organizations (upon a manual change).

If there are more than one Sales Organization/Unit for the respective Distribution Channel and Division, the system arbitrarily picks one from the list.

Resolution

This is expected system behavior. As a workaround, you can change the Sales Unit manually instead and the corresponding Sales Organization will be derived correctly.

See Also

Party Role Determination in a Sales Document for Cloud for Customer

Keywords

Sales Unit, Dales Data, Sales Organization, Distribution Channel, Division, Customer, Account, Opportunity, Determination , KBA , LOD-CRM-OPP , Opportunity Management , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions