Symptom
Compensation values have changed in worksheets without any user editing or inputting different values.
Environment
- SuccessFactors Compensation
Reproducing the Issue
-
Launch Compensation worksheets in your instance.
- Values will be entered onto the worksheet by a Manager or HR Manager on the second or third step of the route map.
- The starting point for eligibility in the template will be "No employees are eligible".
- Then the customer will do a Mass Update of worksheets by choosing the "Update all worksheets" option in the Template.
- The customer will choose the following two options when using "Update all worksheets".
- "Update Compensation Worksheets to reflect employee's eligibility changes (if any).
- "Rules already set up through the Compensation Template's Eligibility Rules Engineer. Apply those to the Compensation Worksheets as Well."
- The customer will choose to do another "Update all worksheets" job before the first "Update all worksheets" job completes with the two options mentioned above chosen.
- The customer will then notice by navigating to the Compensation worksheets that certain values have been changed to zero.
- The customer can also notice these changes by running the "Compensation Plan Activity Audit" and seeing in the report the date and time of the changes.
Cause
-
If a customer chooses to run a "Update all worksheets" job after a previous "Update all worksheets" has not been completed will cause values to change in worksheets.
-
Before the first job is complete, the second job will start re-applying the eligibility rule.
- The second job will start re-applying the eligibility rules and will clear the eligibility flag in the database.
- This will mean all employees become ineligible because of the starting point of "No employees are eligible", hence the values in the worksheets will revert back to zero such as Merit, Lump Sum.
- Meanwhile the first job is still updating worksheets. It loads the eligibility flag of employees for one worksheet and will set their status as ineligible.
- So it will reset all data fields of these employees to empty/zero.
- Eventually the second job will complete and load all the Eligibility flags correctly and values will be eventually be restored. (You will also be able to view these changes in "Compensation Plan Activity Audit" report.)
Resolution
-
It is best practice for customers to never schedule or run multiple mass update jobs in parallel for the same template.
- While the system is still updating the Compensation worksheets, we recommend you not to initiate another update simultaneously or access the worksheets and Executive Review.
- Be aware that before the completion of the first job, updating the worksheets again for the same template could lead to unexpected changes to the data in Compensation worksheets.
Keywords
compensation, update, eligibility, values, values defaulting, compensation data blank, blank comp data , KBA , LOD-SF-CMP , Compensation Management , Problem
Product
SAP SuccessFactors Compensation all versions ; SAP SuccessFactors HCM Core all versions