Symptom
When you try to change the validity of a business user of the system, it does not change the validity of the respective employee.
In the reverse scenario (edit the validity of the employee), the business user validity is modified.
Environment
SAP Hybris Cloud for Customer - all versions
Reproducing the Issue
-
Go to the Administrator work center.
- In the General view, click on Business Users.
- Select an user.
- Click on the button Edit -> Attributes.
- In this screen, change the Valid To date and save.
- Now go to the People work center.
- Navigate to the Employees view.
- Open the respective employee.
- You can see that the Valid To date was not modified.
Cause
Since the employees need a business user to access the system, the modifications in the employee will be reflected directly into the business user of the system.
However the modifications in the business user in terms of validity does not affect the respective employee, as the technical terms of the user (such as password lock, access rights, etc) must not influence in employee HR terms (hire and working times of the employee in the company).
Resolution
The system works as expected.
Keywords
Employee, Valid To , KBA , AP-BP-EE , Employee , How To