SAP Knowledge Base Article - Public

2629036 - Submit for Approval Action not Available in a Lead

Symptom

You have created an Approval Process for Leads in status Accepted; however when the Lead is in this status, the Action Submit for Approval or Withdraw from Approval is not available.

Environment

SAP Cloud for Customer

Reproducing the Issue

Prerequisite: a valid Approval Process for Leads in status Accepted.

  1. Go to the Sales workcenter.
  2. Go to the Leads view.
  3. Open any Lead with status Accepted.
  4. Click Action.

Result: the Action Submit for Approval or Withdraw from Approval is greyed out.

Cause

While the status Accepted is available during the set up of the Approval Process, the system does not allow using it within the Approval Process. In the definition of the Approval Process, currently there is no check available to allow the validation whether the selected value is valid or not.

The same applies for the Lead status Declined or Converted.

Resolution

Please choose another status for the Approval process.

Keywords

approval process, leads, accepted , KBA , LOD-CRM-LM , Lead Management , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions