SAP Knowledge Base Article - Public

2630032 - Field Reason Code Not Available in the Lead. Error: "Please Enter a Reason Code"

Symptom

When editing the status of a Lead you faced the warning message "Please enter a reason code", but the field Reason Code is not available in the UI.

Environment

SAP Hybris Cloud for Customer

Reproducing the Issue

  1. Go to the Sales work center.
  2. Go to the Leads view.
  3. Open the lead ABC (ABC represents the lead ID).
  4. Update the Status field with a value which a reason code is mandatory, e.g. Accepted.
  5. The warning "Please enter a reason code" appears, but the field Reason Code is not available.

Cause

You need to add the Reason Code field in the screen layout.

Resolution

  1. Go to the Sales work center.
  2. Go to the Leads view.
  3. Open the Lead ABC (ABC represents the lead ID).
  4. Press Adapt -> Edit Master Layout.
  5. Press the Edit button of the Lead.
  6. Update the Status field with a value which a reason code is mandatory, e.g. Accepted.
  7. Hover the mouse over a field in the header until the + icon appears.
  8. Press + -> Add fields.
  9. Add the field Reason Code.
  10. Finish the layout changes.

Keywords

Reason Code, Leads, Layout, Status, Not Available , KBA , LOD-CRM-LM , Lead Management , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions