Symptom
When editing the status of a Lead you faced the warning message "Please enter a reason code", but the field Reason Code is not available in the UI.
Environment
SAP Hybris Cloud for Customer
Reproducing the Issue
- Go to the Sales work center.
- Go to the Leads view.
- Open the lead ABC (ABC represents the lead ID).
- Update the Status field with a value which a reason code is mandatory, e.g. Accepted.
- The warning "Please enter a reason code" appears, but the field Reason Code is not available.
Cause
You need to add the Reason Code field in the screen layout.
Resolution
- Go to the Sales work center.
- Go to the Leads view.
- Open the Lead ABC (ABC represents the lead ID).
- Press Adapt -> Edit Master Layout.
- Press the Edit button of the Lead.
- Update the Status field with a value which a reason code is mandatory, e.g. Accepted.
- Hover the mouse over a field in the header until the + icon appears.
- Press + -> Add fields.
- Add the field Reason Code.
- Finish the layout changes.
Keywords
Reason Code, Leads, Layout, Status, Not Available , KBA , LOD-CRM-LM , Lead Management , How To
Product
SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions