Symptom
You are replicating materials to C4C , incoming message fails with error "Product assignment to product category XYZ(XYZ represents a product category) not permitted"
Environment
SAP Hybris Cloud For Customer
Reproducing the Issue
1) Go to Webservice Message Monitoring in C4C
2) Filter with status "Application Error" and Service Interface "MaterialReplicationInitiatedByExternalIn"
3) Navigate to error log "Product assignment to product category XYZ not permitted"
Cause
The indicator "Product Assignment Allowed" is set to false/disabled for the relevant product category(Product Categories view of Products workcenter)
Resolution
1) As per the standard integration content, if you replicate product categories from ERP system, we will send the "ProductAssignmentAllowedIndicator" as TRUE by default and this issue will not occur.
2) If you either enhance the mapping or if you create product categories in C4C manually via migration/mass data maintenance with this indicator as "FALSE", then you have to enable this indicator for relevant product category.
3) Then restart the incoming message and it will be processed successfully
Keywords
Product Replication to C4C; Product Category in C4C; Product Assigment not possible , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , Problem