SAP Knowledge Base Article - Public

2630281 - When checking out from Cart with coupon, user receives error: The shopping account you are using does not support any payment methods

Symptom

When using a coupon that reduces the value of the shopping cart to 0, when Checking out the shopping cart, the error "The shopping account you are using does not support any payment methods" is presented. Note that it only happens if only "Purchase Order" payment method is configured for the User.

Environment

SuccessFactors Learning Management System (LMS)

Reproducing the Issue

  1. Order an item (via shopping cart, User needs to have an External Purchase account in Commerce);
  2. Apply a coupon of 100%;
  3. Checkout;
  4. Message is displayed: The shopping account you are using does not support any payment methods.

Cause

There is no Purchase Order associated with the User or the User's Organization.

Resolution

There must be a Purchase Order associated to the user or user's organization if Chargeback or Credit card is not enabled. By default for an external user Purchase Order is enabled but the Admin has to create and associate a Purchase Order to the User. You can follow the steps below for it:

  1. Admin->Commerce->Purchase Orders;
  2. Add new Purchase Order OR use existing Purchase Order;
  3. Associate the user or user's organization to the Purchase Order.

Keywords

Shopping Cart, Add to Cart, Checkout, Coupon, 0, 100%, Free, The shopping account you are using does not support any payment methods. , KBA , LOD-SF-LMS-COM , Commerce , Problem

Product

SAP SuccessFactors Learning 1708 ; SAP SuccessFactors Learning 1711 ; SAP SuccessFactors Learning 1802