Symptom
When replicating Business Partner from CRM, S/4HANA or ERP to C4C the Industry field is not getting updated.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Administrator work center.
- Open the General Settings work view.
- Click on the Web Service Message Monitoring.
- Search for the Service Interface.
- You will be able to see the error.
- Select the respective message.
- Click on Restart.
Cause
This is happening because in the external system (CRM, S/4HANA or ERP) the Standard checkbox, under Industries is not flagged.
You can check on the C4C payload the following to confirm the behavior:
<IndustrySector actionCode="04">
<IndustryClassificationSystemCode>123</IndustryClassificationSystemCode>
<IndustrialSectorCode>123</IndustrialSectorCode>
<DefaultIndicator>false</DefaultIndicator>
Default Indicator is set as false.
Resolution
To replicate Industry to C4C, the Standard checkbox should be flagged in the OnPremise side. Hence, the DefaultIndicator field on C4C payload will be set as true.
As part of the standard integration scenario only one IndustrySector field can be updated in C4C.
See Also
Keywords
Industry field. , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , How To