Symptom
You have assigned role Employee, Sales Data of the Employee to a user, but s/he does not see some objects which have the same sales data.
Environment
SAP Hybris Cloud for Customer
Reproducing the Issue
Prerequirements: Role Employee, Sales data of Employee is assigned to a user.
These steps are just an example. The same behavior can happen in other work centers, too.
- Go to the Administration work centre
- Go to the General Settings view.
- Click on Employees.
- Search the employee linked to the user affected.
- Check the Sales Data assigned to the employee ABC (ABC represents the name of the employee/user who is affected).
- Log in to the system as user ABC.
- Go to the Customers work centre.
- Go to the Accounts view.
- Search for an account which has the same sales data as user ABC.
Result: You cannot find the account.
Cause
The access restriction 5 - Employee, Sales Data of Employee is a combination of two different restrictions (Employee and Sales Data of the Employee).
- EMPLOYEE restriction means that if an account has an employee/s responsible/s (an owner or some members in the Account Team), the account will be just visible to them.
- SALES DATA OF THE EMPLOYEE restriction means that if the account has the same sales data as the user, the account will be visible for that user.
Both conditions have to be met if you want that the object visible for user ABC.
Resolution
You can either remove the employees assigned to that object (for example, Account) or assign a more appropriate role to user ABC.
See Also
2533411 User With Access Restriction For Sales Unit Can See Sales Documents of Other Sales Units
2438094 Orphan Objects Still Visible After Scoping
Keywords
business role, business user, Employee, Sales data of the Employee, account, sales data, access rights, 1050 , KBA , LOD-CRM-ACC , Account , Problem