SAP Knowledge Base Article - Public

2630574 - Transfer Action Is Grayed Out on Contracts When the User Tries to Replicate to External System

Symptom

The transfer action is grayed out when the user tries to replicate the contract to external system.

Environment

SAP Cloud for Customer 1802

Reproducing the Issue

  1. Go to the Contracts work center.
  2. Go to the Contracts view.
  3. Open a contract ABC (ABC represents the ID from Contracts).
  4. Click on Actions.
  5. The trasfer option is grayed out.

Cause

The transfer status is "In process". The contract was transferred to ERP and there is communication between the C4C and the external system.

Resolution

This is the system expected behavior. The idea of this transfer status is to avoid any changes until the remote system sends back a response message with the current data.

The user can verify the transfer status on Changes facet. Besides, the user can personalize the Contract ABC and add field "Transfer Status" on the Contract's header following the steps:

  1. Go to the Contracts work center.
  2. Go to the Contracts view.
  3. Open a contract ABC (ABC represents the ID from Contracts).
  4. Click on Personaliz.
  5. Click on Start Personalization.
  6. Hold the mouse's arrow over a field on the Contract's header and click on Add Items.
  7. Click on Add Fields.
  8. Flag Transfer Status.
  9. Click on Apply.
  10. Click on Personalize.
  11. Click on End Personalization.

Keywords

ERP, CRM, External System, Contract, , KBA , LOD-LE-COP-SLS , Sales Contract , LOD-LE-COP-SRV , Service Contract , How To

Product

SAP Cloud for Customer add-ins 1802 ; SAP Cloud for Customer add-ins 1805 ; SAP Hybris Cloud for Customer add-ins 1711