Symptom
You are facing the error below when updating Service Requests via Mass Data Maintenance:
"Missing key specification for processing node SERVICE_REQUEST TextCollection.TEXT
Update not possible; existing data for TEXT not fully specified"
Environment
SAP Cloud for Customer - all its versions.
Reproducing the Issue
-
Go to the Mass Data Maintenance work center;
-
Click on Import Service Request link;
-
Upload the files in "General" tab and "Descriptions and Notes" tab;
-
Click on Execute Data Import and get the mentioned errors.
Cause
The file you are using to import the "Description and Notes" information of Service Request contains more than one case Description and this is not allowed.
Resolution
You should keep only one case Description and have the other notes, with Note Type as Internal Comment.
Also, via Mass Data Maintenance it is only possible to update the already existing notes. If you want to add new notes, the suggestion is to use Data Workbench, which allows you to import new notes to an existing Service Request. The notes should be of type case Description (10004) (only one per service request) or Internal Comment (10011).
Keywords
service request, notes, case description, internal comment, mass data maintenance, import, update, ticket , KBA , LOD-CRM-SRP , Service Request Processing , Problem