SAP Knowledge Base Article - Public

2630975 - How to Determine a Performance Issue With a Save and Open Operation

Symptom

You notice an issue with Quick Create for a particular object such as Sales Orders, Accounts in which the Save and Open Operation has a very long response time.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. In your SAP Cloud for Customer Responsive UI Tenant, navigate to the desired work center, for example Accounts.
  2. Click on the + button on the bottom left of the screen to open the Quick Create.
  3. Enter all the required information.
  4. Click on Save and Open.
  5. Now follow the same steps but only press Save.

Cause

Included in the Save and Open Operation is the load time of the Thing Inspector. If there are any objects on the Thing Inspector screen such as Reports or Embedded Components, this will add to the total response time.

Resolution

If the issue only occurs with the Save and Open Operation, also test the Save Operation. If the Save Operation has a much shorter total response time, then you know the issue has to be on the Thing Inspector screen and is likely being caused by a Report or Embedded Component which the customer has added. In this case, it is advised to move Reports/ Embedded Components to another facets/tab.

For further information on measuring performance impact due to multiple Embedded Components read through the below blog in the SAP Community in the See Also section.

See Also

How-to measure performance impact due to multiple Embedded Components in a facet/tab

Keywords

Quick Create performance, save and open quick create, roundtrips , KBA , LOD-CRM-PRF , Performance , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions