SAP Knowledge Base Article - Public

2631048 - Extractor Setup for HANA system fails due to CX_DUPLICATE_TEMPL_DEFINITION

Symptom

Step Extractor Setup for HANA system or ABAP/Java with HANA Database in Managed Systems Configuration fails as below,

ActivityDIAG_MNGD_EXTRACTORS ended with statusError for system <SID>/ABAP Message:An error occured during EFWK Setup. For Details please check TA SLG1 (Object: e2e_alerting / Suboject: efwk_setup).

When going to transaction SLG1, the following error message can be found,

Start
Used system to get templates: <SID> HANADB [active]
CX_DUPLICATE_TEMPL_DEFINITION: The processed template definition is not unique. Store Templ. ID = '8
5F32EE7F74838DC6F9EFE961C1456078CFEF5C3' , Technical System ID ='[active] <SID>~HANADB'. [CX_DIAG
ST_RETRIEVE_EXCEPTION]

Caused by
Program: CL_DIAGST_TS==================CP
Include: CL_DIAGST_TS==================CM00E
Source line: 143

Environment

SAP Solution Manager 7.1

SAP Solution Manager 7.2

Reproducing the Issue

Execute step Extractor Setup in Managed Systems Configuration.

Cause

 Due to some certain reason, a duplicate HANA server exists in LMDB.

Resolution

  1. Go to LMDB and check the HANA technical system as below, a duplicate server should be found under technical instances, in this case, the duplicate one should be deleted.
    HANA servers.png
  2. Re-exeucte the step Extractor Setup.

Keywords

CX_DUPLICATE_TEMPL_DEFINITION;DIAG_MNGD_EXTRACTORS; , KBA , SV-SMG-DIA-SRV-EFW , Extractor Framework , Problem

Product

SAP Business ByDesign all versions