SAP Knowledge Base Article - Public

2631487 - Export is Interrupted in Data Workbench

Symptom

You try to export data for an object in Data Workbench and when you check on the progress of the export in the Monitor view, you see that the task has been interrupted.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Data Workbench work center.
  2. Select the Export view.
  3. Choose the object to export.
  4. Click the radio button All Data or filter by any available criteria.
  5. Click Next, then click Export Data.
  6. Go to the Monitor view and see the task is finished with Interrupted status.

Cause

The issue might be related to one or both of the following reasons:

  • If the task is interrupted almost immediately, it is more than likely related to a duplicate field in the chosen object. Two properties with the same name may be present, one of them more than likely being an extension field.
  • The amount of records might be too high. The export is expected to work up to about 500.000 records, but depending on the header data (e.g. amount of extension fields) it might be even less.

Resolution

  • To solve immediately occurring errors, the best course of action is to remove one of the fields from the OData Service and then try the export again. It should go through successfully.
  • To solve errors for export with too many records, split the export into different export tasks below the limit of about 500.000 records.

See Also

Data Workbench > Export Help Portal

Keywords

Data Workbench, Export, Interrupted, Duplicate field , KBA , LOD-CRM-INT-DWB , Data Workbench , How To

Product

SAP Cloud for Customer core applications all versions