Symptom
You have configured the values for Service Category / case Category under Service Entitlements. When you logon in English envrionment, all the values show correct in the Object Value Search of Service Category. However, when you logon in other environment (like German, French), the Object Value Search shows as blank.
Another scenario is, you maintained the service catalog in English system, and when you login using another language, the same is empty.
Environment
SAP Cloud for Customer
Reproducing the Issue
Prerequisites:
In English Environment, under Service Entitlements work center >> Service Categories, here you have maintained Service Categories.
Logon in any Language Envrionment other than English (like German or French).
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Go to Service work center.
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Go to Tickets.
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Create a new ticket or open an existing ticket.
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Click the OVS (object value search) of field Service Category or case Category.
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You found that the result of the OVS is blank. No categories shows in the list as below.
Cause
You just maintained the Service Category details in English. There is no other languages defined for the categories.
Resolution
There are 2 ways to maintain multiple languages for category.
Method 1:
- Logon the related Environment (for example: Logon German environment).
- Navigate to Service Entitlements work center.
- Navigate to Service Categories work center view.
- Create a new Catalog as you cannot edit the released one. Maintain the "Category Name" and "Description" in German for every category.
Method 2:
If you would like to create Catalog From File, you can maintain the different languages in the excel in one time, using the format as below: (repeat the 3 columns as Language, Name, Description for different language imput, see Language1, Name1, Description1 and Language2, Name2, Description2 . You can define many language sets based on this pattern in Excel.)
Keywords
OVS (Object Value Search), Service Category, Ticket, Language, Service Catalog, Catalog, Empty, German, French, English, C4C, Cloud for Customer, Blank, , KBA , LOD-CRM-SRP , Service Request Processing , How To