Symptom
You've maintained the following account address details in the Account master data. While either in the output or preview of the Sales Document e.g. the Customer Invoice, the additional fields you've maintained don't get populated on the Customer Invoice output layout.
-
P.O. Box
-
P.O. Box Postal Code
-
P.O. Box City
- P.O. Box State
-
P.O. Box Country
You expect above fields to be populated in the Customer Invoice output layout.
Environment
Business ByDesign all versions
Reproducing the Issue
Maintain additional address in Account Master Data.
-
Go to Account Management Work Center
-
Go to Accounts and select respective account
-
Under General tab and Main Address section
-
Click Additional Fields and maintain the following fields:
P.O. Box/P.O. Box Postal Code/P.O. Box City/P.O. Box State/P.O. Box Country
- Save and Close
We will use the Customer Invoice as an example.
Check in Customer Invoice Preview.
- Create a Customer Invoice for this account
- In the respective Customer Invoice, click Preview
- Only the following fields have been populated on the Customer Invoice layout
- Country
- Address Line 1
- Address Line 2
- Street/House Number
- Address Line 4
- Postal Code/City
Cause
The address is calculated at runtime via the API GET_FORM_ADDRESS_FROM_BUFFER which would get Street address in return as a priority if both Street and Postal address are maintained in the Account Master Data.
Which means if you've maintained main house address in the Account Master Data, it will overwrite the P.O. Box Address in the Form Template.
Resolution
This is the current system behavior.
Keywords
Customer Invoice Layout, Additional Address, P.O.Box address, Account; Form Template; PO Box; missing; not visible; Bill To; Sales Order; Form Template; Sales Quote; Service Order , KBA , AP-CI , Customer Invoice Processing , AP-SLO-SO , Sales Order , How To