Symptom
- Workflow Email have been customized to be sent to specific participant in the workflow. eg. CC role such as empoloyee's manager
- CC Role (i.e the manager) receives two Emails Notification for the Same Workflow - The customized email and the standard email, although the standard emails is turned off in the Workflow Email Configuration screen.
- Why are some recipients receiving more then one workflow notification email?
Environment
SAP SuccessFactors Employee Central
Reproducing the Issue
Pre-Requisites:
- All users are on the same language.
Steps:
- Configure a Workflow
- Configure Customized Email Notification in Workflow Email Configuration screen
- Turn off standard emails is turned off in the Workflow Email Configuration screen.
- Trigger a worflow
- CC role will receive two messages (The standard and the customized)
Results:
- CC is the employee's manager, he receives the customized email and the standard email, although it had been turned off in the Workflow Email Configuration screen.
Cause
The Expected Behaviour is as follows:
- The Customized Email Notification must be enabled for all workflow participants for it to work correctly.
- If email configuration is enabled only for CC role, then standard email will be dispatched too.
- Customized Email Notification cannot be configured to be sent to selected participants only.
Resolution
Enable a customized "Workflow Email Notification" for all steps / participants.
Keywords
Workflow Email Notification, CC Role, SFSF, SFEC, EmpCentrl, WFL, CustomWFLEmail, SF EC, success factors , KBA , LOD-SF-EC-WFL , Workflows - Configuration, Tools, Objects & Rules , LOD-SF-EC , Employee Central , Problem
Product
SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Core all versions