Symptom
When accessing the Calendar following error message is displayed: ‘You are not authorized to access the UI application /BYD_COD/SalesOnDemand/Activities/CalendarView/MobileCalendar_OWL.OWL.uicomponent’.
Environment
SAP Cloud for Customer Sales
Reproducing the Issue
- Log into the relevant system.
- Click the Calendar work center view(in Fiori) or icon (in HTML5).
Following error message is displayed: ‘You are not authorized to access the UI application /BYD_COD/SalesOnDemand/Activities/CalendarView/MobileCalendar_OWL.OWL.uicomponent’.
Cause
You have not assigned any activities related work centre views to the affected user.
Resolution
You need to assign the activities related work centre views to the affected user.
In order to do so you need to use the following steps:
- Go to the Administrator work centre.
- Select the General Settings view.
- Click the Business Roles hyperlink, under the Users section.
- Select the relevant business role.
- Assign the Activities work centre.
- Save the changes.
- Update the assigned users.
In case you are not using any activities in the system, this is a new feature requirement, which was already taken into our backlog and will be delivered in one of our future releases.
Keywords
Calendar, Error message, Activities, You are not authorized to access the UI application /BYD_COD/SalesOnDemand/Activities/CalendarView/MobileCalendar_OWL.OWL.uicomponent. , KBA , calendar , activities , you are not authorized to access , calendarview/mobilecalendar_owl.owl.uico , /byd_cod/salesondemand/activities/calend , LOD-CRM-CAL , Calendar Control , LOD-CRM-ACT , Activities , Problem