SAP Knowledge Base Article - Public

2632962 - Error Messages While Activating PDI Solution From SAP Cloud Applications Studio

Symptom

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

 

You will receive error messages as shown below while activating PDI solution from SAP Cloud Applications Studio.

cd2.JPG

Environment

  • SAP Cloud Applications Studio
  • SAP Cloud For Customer
  • SAP Business ByDesign

Reproducing the Issue

  1. Login to SAP Cloud Applications Studio.
  2. Open PDI Solution (e.g. YABCDEFG_).
  3. Open Solution Explorer.
  4. Right Click on Solution (e.g. YABCDEFG_).
  5. Click on Activate.
  6. Select All Items.
  7. You can see error messages:
  • Issue occured in application component:AP-RC-BDS-BC
  • Error during activation in:Business Configuration Object
  • Error while activating BCO YABCDEFG_XYZ of solution YABCDEFG_. Report an incident.
  • Business_Configuration/BCO....bco Error while activating BCO YABCDEFG_XYZ of solution YABCDEFG_ Report an incident.
  • Activation of solution YABCDEFG_XYZ failed

Cause

This error will appear when the BCO files are not Active in the solution.

Resolution

  1. Login to SAP Cloud Applications Studio.
  2. Open Affected Solution (e.g. YABCDEFG_).
  3. Activate All BCO files from SDK.
  4. Activate Solution (e.g. YABCDEFG_).
  5. Right Click and do Deploy Business Configuration.

 

Keywords

Solution Activation, Server Messages, AP-RC-BDS-BC, PDI, SDK, Business_Configuration, BCO, Report an incident, Cloud Application Studio, PDI, SDK, custom , KBA , activation , bc error , AP-RC-BDS-BC , ByDesign Studio Business Configuration , How To

Product

SAP Business ByDesign all versions ; SAP Cloud Applications Studio all versions ; SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions