Symptom
- Application Error appears when taking action (approve/decline) on a workflow
- fingerprint=ff9a6ad23d29ddeb2db935ebcada845ca81ee4bf
- fingerprint=1d25056b50b45e2873e5f5bfcdc0d8282b752dff
Environment
- SAP SuccessFactors HCM Cloud
- Employee Central - b1805
Reproducing the Issue
1. Approve a Hire/Rehire workflow.
2. An Application Error appears and approver is not able to approve the workflow.
Cause
Cause 1:
- There is an invalid configuration for Payment Information
- Payment Information UI has changed since the employee was last hired/active in the system
Cause 2:
- There are Conditional Associations for Payment Information Detail-related objects such as Payment Information Detail USA under Configure Object Definition. This should done as a part of the Configure UI Rules in Manage Business Configuration.
Resolution
For Cause 1 Details:
- A new code stream will be introduced into the product to account for backwards compatibility for scenarios where a Custom User Interface (For example: Payment Information Details Portlet) has been changed since last time a user was hired into the system to account for new fields that were not previously present during last time a user was hired
- This is currently being worked on by our development team
- There is no target release version at this time
- Due to the nature of this feature enhancement, this has to be worked on by multiple teams to ensure a proper release and system stability
Cause 1:
Workaround 1:
- Manually remove the Bank details for the Subject user prior to rehiring the employee
- Rehire the Employee from Manage Pending Hires (MPH)/Rehire MSS UI / Add New Employee
- After the workflows are approved, Add the Payment Information Details back into the users profile
Workaround 2:
- If using ONB/RCM - Remove mapping so that the bank data is not sent to Employee Central during the rehire process within MPH
- After the user is hired and the workflow is approved
- Add the Payment Information Details (Bank Details)
Workaround 3:
- Remove the Workflow for Rehire Scenario
- When a business rule kicks off a Workflow, the data is not actually validated at the database level until the last approver step, if there is no workflow, the data will be written to the database automatically accepting all values as is
- Create a new business rule to put in place (just for the time being), so that the workflow will not trigger for the Rehire Scenario
- Do not delete old rule, as once the new functionality is introduced to the system, we will be able to revert easier to previous configuration
- We will use new rule in place of previous rule for the time being
- Next, create a separate new business rule to trigger an alert to be sent instead of triggering a Workflow
- This alert will provide a means so that there is an ongoing record of the ‘Rehire’ action, and we can add appropriate details using Placeholders & Alert Tags in the notification/alert email to be sent to the proper stakeholders whom need to be notified
For Cause 2 Resolution:
- Remove the Conditional Associations.
- Re-submit the Workflow Request.
- At this point, without the conditional associations, the approver should be able to approve the workflow without error
See Also
2460138 - Application Error during Manage Pending Hires > Rehire | Existing data not transferred to Payment Information in Manage Pending Hires > Rehire
2568012 - Error when Hiring Employee from Manage Pending Hires Onboarding - Payment Information Error Messages
Keywords
application error, hire, rehire, workflow, fingerprint=ff9a6ad23d29ddeb2db935ebcada845ca81ee4bf, ECT-102423, ECT-96474, ECT-56847, SFEC, SFSF, SF EC, success factors, EmplCentrl, WFL, ALR, HIR, RE-Hire, Last Step Approver, ECT-102423 , KBA , LOD-SF-EC-WFL , Workflows - Configuration, Tools, Objects & Rules , LOD-SF-EC-HIR , Hire & Rehire Wizards , LOD-SF-EC-PAY , Payment Information (Bank Information) , Problem