Symptom
You have created and added some Extension Fields to one tab (facet) in the system. However, there is no option to set these Extension Fields as mandatory.
Environment
SAP Hybris Cloud for Customer
Reproducing the Issue
- Go to Customer Workcenter.
- Go to Accounts View.
- Open Account XYZ (where XYZ is one example of account).
- Go to Sales Data Tab.
- Adapt the screen.
- Try to set the properties of one Extension field as mandatory.
Cause
It is not possible to set Extension Fields as mandatory when these fields are under preview panes.
Resolution
This is a expected system behavior.
If you need this functionality urgently you may contact your implementation manager to help with such request or approach directly the SAP Cloud Service Center.
You can find more details about the services offered by Cloud Service Center on https://www.sap.com/services/application-development.html. You can contact Cloud Service Center as follows:
a) If you are a partner: please use cloudsolutionpartner@sap.com or the Partnerfinder
b) If you are a customer: please use the little blue box “Contact Us” shown on the very right-hand side of https://www.sap.com/services/application-development.html, choose “Contact Us”, choose “Services”, choose “SAP Custom Development” and complete the page
Note: The services of the SAP Cloud Service Center will be charged as packaged services based on fixed prices.
An alternative option may be to check the SAP Customer Influencer Site to submit an idea: https://influence.sap.com/SAPCloudforCustomer
Keywords
mandatory; KUT; extension field , KBA , AP-RC-UIF-FLX , Page Layout & Key User Configuration , How To