Symptom
You selected an Access Context (for example: 4 Sales Unit) for the Lead Data Source (ID CODMKLEAH) and realized that it does not work when you open a report built on top of this data source.
Environment
SAP Hybris Cloud for Customer
Reproducing the Issue
-
Open your report (based on the Lead data source) from the Analysis work center.
-
Check the Access Context - it will be restricted or show no restriction.
-
Click on Go.
The report returns no results at all. For this user however, it is expected to show some specific (restricted) results.
Cause
The technical object behind the Lead data source only supports the access context: 1015 Employee, Territory, Account, Sales Data. No other access context (for example Sales Unit) is supported.
Resolution
This is the current system behavior.
Our development team will validate if this behavior can be changed in future releases.
See Also
Keywords
access context; lead; sales unit; data source; CODMKLEAH; report , KBA , AP-RC-ANA , C4C, ByD, Travel: Analytics Tools & Frameworks , LOD-CRM-LM , Lead Management , Problem