Symptom
When trying to use Manage Business Configuration for the first time, or after there has been changes in the data model, it gives an error informing that "The Data models are not synchronized".
This article exists to cover the issues that can happen when using BCUI without Employee Central enabled. For EC Issues go to "See Also" section.
Environment
SuccessFactors Employee Profile
Reproducing the Issue
- Login to SuccessFactors;
- Go to Admin Center > Manage Business Configuration;
- You will see the error "Business Configuration is locked. Data models are currently synchronized. Please try again later." There, informing that the data models are not synchronized, and moving you back to Admin Center.
Cause
When you use Business Configuration UI, every change on the Data Model needs to be synchronized with it. There are some cases when changes applied directly in the XML lack the full information Business Configuration UI needs to display the fields, so it locks down until they are corrected, to prevent inconsistencies.
Resolution
In order to resolve this, please engage a Partner, or our support, in case there has been an issue after an implementation, the partner that implemented it would be the best option.
For this part, Provisioning access is required, so this can be applied by either support or Partners.
First thing to do checking the "Synchronize Business Configuration" job in Monitor Jobs to understand what error is making it fail.
What you will be looking for is an error like "java.lang.NullPointerException: while trying to invoke the method java.lang.String.isEmpty() of a null object returned from com.sf.sfv4.util.LocalString.getDefaultString() at com.successfactors.businessconfig.bean.exits.EPViewTemplateConfigExit.syncDataToMDF(EPViewTemplateConfigExit.java:285)"
In this case, there are missing labels in View Templates. In order for the sync job to succeed all fields need to have default labels. In case a field has only localized labels, like the example below:
<label xml:lang="en-US">Employee Profile</label>
You'll need to add the default label as well:
<label>Employee Profile</label>
<label xml:lang="en-US">Employee Profile</label>
Once default labels are added to all the elements in the datamodel (standard, background, view and edit as well), try reimporting the datamodel and see if the sync job completes. If thats the case the Manage Business Configuration should be accessible again.
See Also
2279497 - Manage Business Configuration is locked
2231503 - Sychronize Business Configuration Sync Job Fails
2360747 - Manage Business Configuration does not show any thing
2274751 - Configure HRIS Sync Mappings in Employee Central using Manage Business Configuration
Keywords
BCUI, EP Business Configuration , KBA , LOD-SF-EP-BGD , Background Elements , Problem