Symptom
Service agent User1 (User1 refers to service agent name) is unable to record times for the project X (X refers to project ID).
Environment
SAP Business ByDesign
Reproducing the Issue
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Go to Project Management work center
- Select Edit Time Sheet view.
- Search for the project task.
The project is not available to perform time recording.
Cause
The service agent is unable to proceed with project time recording because the service agent's supplier is maintained as PQR (PQR refers to Supplier ID) and not updated to the current supplier. Since for intercompany projects the user will be a service agent. Thus, the system picks up the supplier PQR for which the user is made a service agent.
Resolution
Change the supplier for the affected service agent and then reassign them to the project. Once this is done, the supplier will be updated and the service agent will be able to do the time recording correctly for the project. Please follow the below steps to change the supplier of the service agent:
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Go to Project Management work center
-
Select Service Agents view
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Search for the user User1
-
Now click Edit and change the supplier
- Save and Close.
Keywords
Service agent time recording, project time recording, service agent project time recording, unable to record time for project , KBA , service agent time recording , project time recording , service agent project time recording , unable to record time for project , SRD-HR-TLM , Time and Labour Management , AP-PRO , Project Processing , Problem