SAP Knowledge Base Article - Public

2634892 - Service Agents are Unable to Record Time for Project

Symptom

Service agent User1 (User1 refers to service agent name) is unable to record times for the project X (X refers to project ID).

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to Project Management work center
  2. Select Edit Time Sheet view.
  3. Search for the project task.

The project is not available to perform time recording.

Cause

The service agent is unable to proceed with project time recording because the service agent's supplier is maintained as PQR (PQR refers to Supplier ID) and not updated to the current supplier. Since for intercompany projects the user will be a service agent. Thus, the system picks up the supplier PQR  for which the user is made a service agent.

Resolution

Change the supplier for the affected service agent and then reassign them to the project. Once this is done, the supplier will be updated and the service agent will be able to do the time recording correctly for the project. Please follow the below steps to change the supplier of the service agent:

  1. Go to Project Management work center
  2. Select Service Agents view
  3. Search for the user User1
  4. Now click Edit and change the supplier
  5. Save and Close.

Keywords

Service agent time recording, project time recording, service agent project time recording, unable to record time for project , KBA , service agent time recording , project time recording , service agent project time recording , unable to record time for project , SRD-HR-TLM , Time and Labour Management , AP-PRO , Project Processing , Problem

Product

SAP BUSINESS BYDESIGN 1705 ; SAP BUSINESS BYDESIGN 1708 ; SAP Business ByDesign 1702 ; SAP Business ByDesign 1711 ; SAP Business ByDesign 1802 ; SAP Business ByDesign 1805 ; SAP Business ByDesign 1808 ; SAP Business ByDesign feature pack 3.0 ; SAP Business ByDesign feature pack 4.0