SAP Knowledge Base Article - Public

2635152 - Fields Missing From Workflow

Symptom

Few fields are not available for Field update and to be added in Workflow conditions while configuring Workflow Rules.

Environment

SAP Cloud for Customer

Reproducing the Issue

The below is an example using the BO Tickets. The same can happen in other BOs.

  1. Go to the Administrator workcenter.
  2. Go to the Workflow Rules view.
  3. Click New to create a new workflow rule.
  4. Select the Business Object Ticket and enter all the mandatory fields.
  5. Click Next, under the Define Conditions click Add Group to add a condition.
  6. Here, for 'Field' select the dropdown menu.

Some fields such as Coverage are missing from the dropdown menu.

Cause

Only the header level fields of the Business Objects will be available for Workflow conditions or Field updates. Supporting fields at item level cause several techinical complications.

Resolution

This is the expected system behavior. You can attempt to use the SDK to build this feature.

Keywords

condition, update, standard field , KBA , item , update , LOD-CRM-WKF , Workflow , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions