SAP Knowledge Base Article - Public

2635472 - Import schedules intermittently fail in SAP Analytics Cloud (SAC)

Symptom

  • Import schedules intermittently fail in SAP Analytics Cloud (SAC)
  • Error occurred in SAP AC agent service: while trying to load from index 16 of an int array with length 13, loaded from static field sun.until.calendar.basecalendar.accumulated.days.in.month

Environment

  • SAP Analytics Cloud 2018

Reproducing the Issue

  1. Create several Models using one of Import Data Connection
  2. Schedule these models to refresh and import data at the same time every hour
  3. The schedule fails intermittently.

Cause

When multiple import schedules run simultaneously,  the load and required resource are high on the Tomcat hosting SAP Analytics Cloud Agent.

Resolution

  • Spread out schedules to avoid running together thus they do not pull data together
  • Increase Tomcat memory size

See Also

Your feedback is important to help us improve our knowledge base.
Please rate how useful you found this article by using the star rating feature at the beginning of this article.
Thank you.

Keywords

EPM, SAP Cloud for Planning, sc4p, c4p, cforp, cloudforplanning, EPM-ODS, Cloud for Analytics, Cloud4Analytics, CloudforAnalytics, Cloud 4 Planning, BOC, SAPBusinessObjectsCloud, BusinessObjectsCloud, BOBJcloud, BOCloud., SAC, SAP AC, Cloud-Analytics, CloudAnalytics, SAPCloudAnalytics , KBA , "data import" , import/export job failure , LOD-ANA , SAP Analytics Cloud (SAC) , LOD-ANA-BI , Business Intelligence Functionality, Analytic Models , LOD-ANA-PL , Planning , LOD-ANA-BR , SAC Boardroom , LOD-ANA-PR , SAC Predictive , Problem

Product

SAP Analytics Cloud 1.0