SAP Knowledge Base Article - Public

2635943 - Workflow Rule Fail due to Lock Behavior

Symptom

You would like to know how the system behaves when a workflow rule fails due to a lock.

Environment

SAP Hybris Cloud for Customer 1805 and future versions.

Reproducing the Issue

  1. Go to the Administrator work center.
  2. Go to the Workflow Rules view.
  3. Select the line for Workflow Rule XYZ (XYZ represents the Name of the Workflow Rule).
  4. Click on the cogwheel icon for Actions and select Rule Log.
  5. See that the Workflow Rule XYZ contains failed entries, but also successful ones.

Cause

Whenever a workflow rule fails due to a lock, system will retrigger it so the action to be done by the rule is completed. The workflow engine works via packages, so whenever a rule fails, it will be retriggered as soon as another rule is triggered or in the next hour, if no other rules are triggered in the meantime.

The system will keep trying to trigger the rule until it is successful or until another fail reason is given.

Resolution

This is the expected system behavior.

If the feature/functionality is needed as a matter of urgency, please refer to KBA 3475641 - Functionality Currently not Available.

Keywords

Worfklow Rule ; Lock ; Fail ; Failure ; Behavior ; Trigger , KBA , LOD-CRM-WKF , Workflow , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions