SAP Knowledge Base Article - Public

2636240 - National ID Error: Country/Region of National ID must be the same as country/region of legal entity due to restricted permission

Symptom

You're getting error "Country/Region of National ID must be the same as country/region of legal entity due to restricted permission" when adding/editing National ID information.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Employee Central

Cause

From 1805 release, with the permission setting "National ID (Restricted to only country of legal entity)", customers can restrict the access of users to only the relevant National ID (i.e. the National ID of the country of employment). Any other National ID (e.g. those of other countries entered in the context of previous employment) will not be allowed.

Resolution

Customers who want to prevent their users from viewing any National IDs stored in Personal Information that do not belong to the country of the actual employment (determined by the legal entity) but relate to previous employment in different countries on privacy reasons, can now do so with this new permission setting.

Customers can search in the "Role-Based Permissions Troubleshooting Tool" to see from which role the user is getting this restricted permission.

How to enable/disable the permission

  1. Navigate to Admin Center > Manage Permission Roles
  2. Open the Permission Role you wish to update
  3. Click the Edit button > Next
  4. In the left panel, under the "User Permissions" section, select "Employee Data"
  5. In the right panel scroll down to the section "HR Information" and enable/disable both the View and Edit permissions for "National ID (Restricted to only country of legal entity)" as per your business requirement

SPECIAL NOTE: For this permission to work, the user must also be granted with the "National ID Information" permission as well.

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FAQ

Q) When this permission is granted, will the user still see the National ID information for other countries (not the country defined in the employment)?
A) No. The end user will only be able to view the National ID's that are for the same Country as the employees Employment (Country of Legal Entity).

Q) When I enabled this new permission, will this restrict the view of the Countries list when adding National ID's to an employee?
A) No. But you will receive an error message when trying to save a National ID Card for a country that differs from the Country of the Legal Entity of the employee in Job Information.

Q) Should I grant this permission to all users?
A) This permission should be given to users who maintain National ID information. This permission should not be granted to users or roles that require flexibility to add other National ID Cards to employee's where the National ID Cards country differs from that of the Legal Entity of the employee.

Q) Should users only be granted the permission "National ID (Restricted to only country of legal entity)"?
A) If the user needs to add National ID's, then they must still be granted with permission to "National ID Information" as well as then being granted permission to "National ID (Restricted to only country of legal entity)".

Q) When we have an Employee that has multiple National ID's maintained, if this permission is granted to the end user, will they still be able to edit/maintain the National ID for other countries?
A) No. The end user will only be able to successfully edit the National ID's of the country of their employment.

Q) Can this error message be changed/avoided even when this permission is enabled?
A) No. It's a hard-coded message and it cannot be changed/avoided. If you do not want this message, ensure that the respective permission is not enabled in any permission role of the user.

Q) Is it possible to restrict this permission to some fields only allowing the user to edit/enter values to other fields of National ID portlet?
A) No. This permission is appliable for all fields in the portlet. If a user gets this permission from at least one permission role, it'll prevent the user from entering/editing National ID card information details for any country other than his/her Job Information's Legal Entity's country. The following enhancement already exists for field-level permission control of portlets like National ID: https://influence.sap.com/sap/ino/#/idea/237453

See Also

2093378 - National ID validation issues - Employee Central

2255508 - Can you disable National ID validation?

2668688 - National ID Card: How to create custom Regular Expression and Display Format

2472343 - How to Manage National ID Formats via Manage Business Configuration (BCUI)

2923091 - Error: National ID XYZ already exists for country/region ABC and card type MNP

2268770 - Error: In the country/region-specific XML file, define a format for national ID type *** for ***

Keywords

ec, employee central, national id, nationalIdCard, 1805, ECT-93958, National ID (Restricted to only country of legal entity), Country/Region of National ID must be the same as country/region of legal entity due to restricted permission, permission, RBP, restriction, prevention, prevents, restricts, validation, configuration, role, stop, avoid, employment, allow, identity, 237453, field level , KBA , LOD-SF-EC-PER-NAT , National ID - Config, Rules, RBP, UI , LOD-SF-EC-PER , Person Data (All Person Data Types) , Problem

Product

SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Suite all versions