Symptom
- An old template was copied and the route map for the new template was modified.
- The behavior is acting differently.
- For example, in the Template the user is not able to rate themselves or input comments during a specific step.
- In the new template with the modified route map, the users are able to edit all fields.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Performance Management
Cause
- There may be business requirements of changing the current Performance Form's Route Map with a new and updated one.
- Usually, the route map is changed via Admin Center > Manage Templates > [[Name of the PM Template]] > General Settings.
Effect
Changing Performance Form's Route Map via Manage Templates may cause inconsistency in the Performance forms' permissions, removing them.
Resolution
This is an expected behavior of the system, when changing the route map directly on Manage Templates > [[Name of the PM Template]] > General Settings > Change the Route Map. Changes to the route map applied through the Manage Template configuration page, will remove the previous configuration of the template.
Thus, always change the Route Map of the Performance Template following the steps below:
- Admin Center > Form Template Settings
- [[Name of the PM Template]] > Select a new Route Map
- Scroll down and click "Save":
Note: The above method will retain the configuration of the Performance form, such as field permissions and action permissions.
Keywords
SF, SuccessFactors, Permission, Route Map, PM Form, PM Template, Settings, Copy Template, Manage Templates, Changing Route Map , KBA , LOD-SF-PM-MAP , Routing, Route Maps & Workflows , LOD-SF-PM-ADM , Admin Center, RBP, Permissions and Settings , Problem