Symptom
When accessing Date Subject information you are greeted with the error message below:
Error : Error fetching report list: {"requestUri":"/odata/v2/restricted/EMMonitoredProcess,Attachment,InformationDataSubjectRequest,InformationDataSubjectResult,InformationDataSubjectPurposeConfiguration,InformationDataSubjectConfigurationTemplate/InformationDataSubjectResult?$expand=csvReportNav%2CpdfReportNav&$select=externalCode%2CdataSubjectId%2CdataSubjectType%2CinstanceId%2CjobId%2CcsvReportNav%2FattachmentId%2CpdfReportNav%2FattachmentId&$filter=createdDateTime%20ge%20datetime'2018-01-24T15%3A13%3A53.372Z'","statusCode":400,"statusText":"Bad Request","headers":[],"body":"{
\"error\" : {
\"code\" : \"COE_PROPERTY_NOT_INCLUDED\", \"message\" : {
\"lang\" : \"en-US\", \"value\" : \"[COE0022]property(ies) InformationDataSubjectResult/csvReportNav not included in the context\"
}
}
}"}
Environment
SAP SuccessFactors HCM Suite
Cause
This issue can occur with customers do not have Employee Central or do not have it configured.
Resolution
If you do not have Employee Central, the following actions need to be taken to use Data Subject information.
- After EC is deactivated the "Enable the Attachment Manager" needs to be switched on in Partner Provisioning, this can be done by your implementation partner.
- The User using Data Subject Information needs to have Attachment Import and Attachment Export Permissions.
- Perform an ODATA Metadata refresh in Admin Center.
After completing the above actions the error should no longer occur.
Keywords
Data Subject Information, DSI, COE022, COE_PROPERTY_NOT_INCLUDED , KBA , LOD-SF-INT-ODATA , OData API Framework , LOD-SF-INT , Integrations , Problem