SAP Knowledge Base Article - Public

2637242 - Personal Data Removal Using Data Protection And Privacy

Symptom

After deleting a contact using the Data Protection and Privacy workcenter , you find that the Lead associated to this Contact is also deleted.

Environment

SAP Hybris Cloud For Customer

Reproducing the Issue

  • Go to Data Protection and Privacy workcenter
  • Select Personal Data removal view
  • Select required Contact
  • Select Removal Data button

To check the Contact:

  • Go to Customers workcenter
  • Select Contacts
  • Search for the required Contact, it does not exist

To check the Lead:

  • Go to Sales workcenter
  • Select Leads
  • Search for the required Lead, it does not exist

Cause

Delete or depersonalize data from all transactional documents.

The processing of personal data is subject to applicable laws related to the deletion of this data when the specified, explicit, and legitimate purpose for processing this personal data has expired. If there is no longer a legitimate purpose that requires the use of personal data, it must be removed. When removing data in a data set, all referenced objects related to that data set must be removed as well.

Remove Personal Data in Contacts:

If an individual account is deleted, all appearances in any party role for this instance in transactional documents are depersonalized unless it is blocked for deletion.

  • You have successfully removed all work agreements (and associated application data) and availability calendars from the system for the selected entity.
  • You can verify this removal by starting the Administer Data Removal Runs common task, and selecting Successful Removal Runs in the Show field.

Remove Personal Data in Leads:

The depersonalization function allows you to remove personal data from a business object to ensure compliance with the applicable data protection requirements. Depersonalization is only available for users with access to the Data Protection and Privacy work center. In Leads, depersonalization triggers a deletion. Once a lead is depersonalized, You can view the deleted data Following the below steps:

  • Go to Administrators workcenter
  • Select General Settings
  • Select Data Management
  • Select Deleted Data to view the deleted record

You cannot depersonalize a lead if it contains a person that is blocked for removal. In case you need to retain certain information, you can download relevant data using OData or Data Workbench prior to depersonalization.

Resolution

It is expected system behavior.

Refer to the below link to find how Depersonalize Transactional Data works:

https://help.sap.com/viewer/cea15f900ca04c4faa35d3044577fe27/1805/en-US/cb33e249d33e4205afc3b5094658436b.html

https://help.sap.com/viewer/637db7a0d01e47009d9420e9a927c571/1805/en-US/327109b8d95c469d8d38db59f38de440.html

 

 Note: Please note bulk deletion/depersonalization of data is not possible currently.

Keywords

Data Removal, Bulk delete, Mass delete, Personal Data removal , KBA , GRC-SPG , SAP Privacy Governance , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions