SAP Knowledge Base Article - Public

2637328 - Updating Pricing Completely Does Not Work for Customer Invoice Request

Symptom

When invoicing an Outbound Delivery Invoice Request and selecting the Update Pricing Completely in the Pricing tab, nothing changes.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to the Customer Invoicing work center.
  2. Go to the Invoice Requests view.
  3. Search for ABC (ABC represents the ID of the Outbound Delivery Invoice Request).
  4. Click on Invoice button.
  5. Navigate to the Pricing tab.
  6. Click on Update Pricing button and then Completely.

The line item price will not change, even if a new Price List with valid dates is set up.

Cause

This happens because in the invoicing scenario, the system will take the Pricing Date of a Invoice Request from the source document, it means the Pricing Date of a Sales Order. Once the Pricing Date is set for the day before of the starting day of a valid Price List, the system will not trigger the update action.

Resolution

To be able to update the prices in the Invoice Request document, the Pricing Date needs to be changed in the source document for the date where the new Price List starts to be valid. After that the Updating Pricing Completely action can be performed again for the Outbound Delivery Invoice Request, and it will change as expected.

Keywords

Update Pricing ; Invoice Request ; Price List; Outbound Delivery Invoice Request , KBA , AP-SLO-SO , Sales Order , AP-CI-CIR , Customer Invoice Request , How To

Product

SAP Business ByDesign all versions