SAP Knowledge Base Article - Public

2638417 - Accounts Basic Search Returns Multiple Records

Symptom

You noticed that, when you search for Accounts using the basic search, it now returns multiple records containing the search term used, for example:

You search for Account ID XYZ and the search returns:

  • Account XYZ.
  • Account XYZDEF.
  • Account XYZABC.

(XYZ, XYZDEF and XYZABC represent the ID of the Accounts)

Environment

SAP Hybris Cloud for Customer 1805 and higher.

Reproducing the Issue

  1. Go to the Customers work center, in Accounts view.
  2. Search for Account ID XYZ, using the basic search.
  3. See multiple accounts have been returned as result.

Cause

The behavior of the records fetched using the search term has changed in the system upgrade to the 1805 version. Before, the system would add the symbol '*' to the end of the search term, such as 'XYZ*' . Now, after the 1805 upgrade, the symbol '*' is also added to the beginning of the search term, so if you search for 'XYZ', the search will actually be '*XYZ*', increasing the results.

Resolution

The system is working as designed.

See Also

This information is also available in the Help Center portal, accessible using the link:  What's New in SAP Hybris Cloud for Customer > Notable Changes

Keywords

basic search, customers work center, accounts view, account search , KBA , AP-RC-UIF-RT , UI Framework Runtime , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions