SAP Knowledge Base Article - Public

2638452 - The Account Main Contact Is Not Determined as the Primary Contact of the Activity

Symptom

The system does not determine the main contact as the Primary Contact of the activity, when you create a new activity from an Account which contains a main contact maintained on Contacts facet.

Environment

SAP Hybris Cloud for Customer

Reproducing the Issue

  1. Go to the Customers work center.
  2. Go to the Accounts view.
  3. Open the account ABC (ABC represents the account ID) which contains a main contact maintained on Contacts facet.
  4. Go to the Activities facet.
  5. Create a new Activity.
  6. The contact XYZ (XYZ represents the contact name) is being determined as the Primary Contact field instead the main contact maintained on Contacts facet of the Account.

Cause

The contact XYZ is maintained as the Contact Person on Relationship facet of the Account.

Then, when you are creating a new Activity on Account, the system will determine the Primary Contact as the Contact Person maintained on Relationship facet of the Account.

Resolution

This is the expected system behavior.

On the Business Configuration -> Activity List -> Activities -> Involved Party for (e.g Appointments), the determination of “Contact of Account” is “Contact of Account”. Hence, the “Contact of Account” is determined as  the Business Partner Relationship of Account which is the “Contact Person” maintained in the Relationship facet of the Account.

The Primary Contact field of an Activity will be filled with the main contact maintained on Contacts facet of the account only if the account does not have any Contact Person maintained on Relationship facet.

Keywords

Main Contact, Primary Contact, Activity, Contact Person , KBA , LOD-CRM-ACT , Activities , How To

Product

SAP Cloud for Customer add-ins all versions