SAP Knowledge Base Article - Public

2638588 - Contract Status Does Not Change From Ready To Active

Symptom

You click on the Activate button of the Contract and expect the Contract status to change to Active, but observe that, the Contract status remains as Ready and the Status field is also grayed out.

Environment

SAP Hybris Cloud for Customer

Reproducing the Issue

  1. Go to Contracts work center
  2. Open the Contract ABC (Where ABC represents the Contract ID)
  3. Click on the Activate button
  4. Contract status does not change from Ready to Active

Cause

The Begins On date of the Contract is in the future. The Contract remains in the status Ready until the Begins On date is reached. A background job changes the status to Active automatically once the Begins On date is reached.

Resolution

This is the standard system behavior of SAP Hybris Cloud for Customer. If you want the Contract to get activated immediately, you could change the Begins On date to the current day or in the past.

Keywords

contract, begins on, contract status, contract active, activate, ready , KBA , contract , contract status , active , LOD-LE-COP , Contract Processing , Problem

Product

SAP Cloud for Customer add-ins 1802 ; SAP Cloud for Customer add-ins 1805