Symptom
You click on the Activate button of the Contract and expect the Contract status to change to Active, but observe that, the Contract status remains as Ready and the Status field is also grayed out.
Environment
SAP Hybris Cloud for Customer
Reproducing the Issue
-
Go to Contracts work center
- Open the Contract ABC (Where ABC represents the Contract ID)
- Click on the Activate button
- Contract status does not change from Ready to Active
Cause
The Begins On date of the Contract is in the future. The Contract remains in the status Ready until the Begins On date is reached. A background job changes the status to Active automatically once the Begins On date is reached.
Resolution
This is the standard system behavior of SAP Hybris Cloud for Customer. If you want the Contract to get activated immediately, you could change the Begins On date to the current day or in the past.
Keywords
contract, begins on, contract status, contract active, activate, ready , KBA , active , contract status , contract , LOD-LE-COP , Contract Processing , Problem