SAP Knowledge Base Article - Public

2639314 - Workflow Business Rules do not trigger a Workflow

Symptom

  • Create a Business Rule to trigger a Workflow - but when trying to trigger the workfow, no workflow is triggered

Environment

Employee Central

Reproducing the Issue

  1. Create a workflow and a business rule to trigger the workflow.
  2. Create a rule trace.
  3. Process a change in order to trigger the rule.

Rule trace is empty, no workflow was created.

Cause

The instance is using Workflow XML configuration for Workflow Derivation

Resolution

Check in Provisioning if "Business Rules for Workflow Derivation" is enabled.

If it is not enabled then the customer is using the Workflow XML configuration instead.

Therefore they must engage with their Partner or SAP Professional Services to have the configuration updated.

Currently there is no automated migration from XML to Business Rules - you must engage with your Partner or SAP Professional Services to manualy recreate the XML scenario's as Business Rules.

Keywords

Workflow rules, xml, Business Rules for Workflow Derivation, ec , KBA , LOD-SF-EC-WFL , Workflows - Configuration, Tools, Objects & Rules , LOD-SF-EC , Employee Central , Problem

Product

SAP SuccessFactors Employee Central all versions