Symptom
You have migrated several appointments using Data Workbench, using employee IDs in the organizer ID column, and noticed that some of these appointments show a different organizer in UI, than originally migrated, and that these different organizers are not employees, but contacts or accounts.
Environment
SAP Hybris Cloud for Customer - all its versions.
Reproducing the Issue
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Go to the Data Workbench work center.
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Import Appointments, using the Import view.
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Go to the Activities work center, in Appointments view.
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Check the Organizer field in the migrated appointments.
Cause
This behavior occurs because the Organizer ID column only accepts Business Partner IDs for the value mapping and conversion. For instance, if you use an employee ID in the organizer ID column and, at the same time, you have a Business Partner of a different type (such as a Contact or an Account) existing in the system, with the same ID of the employee. The system will add the organizer based solely on the Business Partner ID found in the system, making then a Contact or an Account as the organizer of the migrated appointment.
Resolution
To avoid this, you can always use the Business Partner ID from the respective employees you want to migrate as Appointment organizers. To check the Business Partner IDs:
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Go to the Business Partner work center, in Business Partner view.
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Search for the employee names and get the corresponding Business Partner IDs.
Keywords
appointment organizer, organizer ID, organizerID, data workbench, import appointments, activities work center, appointments view , KBA , LOD-LE-RC-PAP , Party Processing , LOD-CRM-INT-DWB , Data Workbench , Problem