Symptom
In the Sales Phase dropdown menu under Advanced Filter for opportunity, it is alphabetically sorted and the Sales Phase is ordered differently in Business Configuration.
Environment
SAP Hybris Cloud for Customer
Reproducing the Issue
-
Go to the Sales work center.
- Go to the Opportunities work view.
- Open the Advanced Search.
- Click on Sales Phase dropdown menu.
- Sales Phases is ordered alphabetically.
Cause
Sales Phases are linked to a Sales Cycle and ordered within Business Configuration. In case of opportunity header, there is Sales Cycle linked and then, based on that, it shows the sort sequence as defined in Business Configuration. However, in case of Advanced Search, there is no context of a Sales Cycle defined. In Advanced Search, the Sales Phase may also be more than one Sales Cycle defined, therefore, it is not ordered as per Business Configuration. The usage semantics is different for Advanced Filter and it is for search purposes.
Resolution
This is the expected system behavior.
If the feature/functionality is required urgently, please refer to KBA 3475641 - Functionality Currently not Available.
An alternative option may be to check the corresponding SAP Customer Influence Site to submit an idea:
Keywords
Sales Phases, Advanced Filter, Opportunity, , KBA , LOD-CRM-OPP , Opportunity Management , How To