SAP Knowledge Base Article - Public

2640232 - Country field is not propagated when changing Legal Entity on History in Job Information

Symptom

  • When editing the Job Information History of an Employee, the field Legal Entity is not getting populated with an updated value that is related to a new country.
  • The configured business rule is behaving as expected and the new value of the country field is not getting propagated correctly. 

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Employee Central

Reproducing the Issue

  1.  Go to Job Information Section

    kb1.png
  2.  Select the History (Clock Icon)
  3.  Select "Insert New Record"
  4.  Change the Legal Entity for a company located in other country
  5.  Without Save the change, check the field country, it will show the previous value and not the new country
    kb2.png
    kb3.png

Cause

  • The engineering team has confirmed this is an expected behavior.
  • The country propagation from the company is specific for Manager Self Service (MSS).

Resolution

  • Instead of using the History of the Job Information, use the edit (Pencil Icon) or the Take Action options.
  • The system will the propagate the correct value.

Keywords

SF, EC, Success Factors, Country propagation, History, Job Information, Legal Entity, ECT-98126 , KBA , LOD-SF-EC-JOB , Job Information , Problem

Product

SAP SuccessFactors Employee Central all versions