Symptom
In the Advanced Filter functionality in the Activities workcenter, for the fields Account, Owner, Contact etc is no value help (OVS) available. The fields are text fields and any value can be entered.
Environment
SAP Hybris Cloud for Customer
Reproducing the Issue
-
Go to the Activities workcenter.
- Go to the Appointments view.
- Expand the Advanced Filter.
Result: For the fields Account, Owner, Contact etc no value help (OVS) is available.
The same applies for the Activities workcenter views Phone Calls, E-Mails and Tasks.
Cause
There are 2 fields for each of those objects: Account and Account ID, Owner and Owner ID, Contact and Contact ID. The OVS is only available for the fields Account ID, Owner ID, Contact ID.
Resolution
Please use the fields Account ID, Owner ID, Contact ID if you want to use the value help when searching in the Activities. If these fields are not available in the Advanced Filters, please add them in the Master Layout:
- Go to the Activities workcenter.
- Go to the Appointments view.
- Click Adapt > Edit Master Layout.
- Expand the Advanced Filters.
- Hover over the available fields and click Add Fields.
- Tick the boxes for the fields you wish to add and click Save.
Keywords
advanced filter, activities, appointments, phone calls, e-mails, tasks, account, owner, contact , KBA , LOD-CRM-ACT , Activities , How To