SAP Knowledge Base Article - Public

2640767 - Custom filter on career site is not working - Recruiting Management

Symptom

A custom filter created to search job postings is not returning any jobs, even although there are jobs meeting the criteria.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

SAP SuccessFactors Recruiting Management

Cause

1. Configuration issue

Usually, this is caused by the wrong configuration in JRDM.
When a custom filter is created, sometimes on the Job Requisition Template the field being used might be a custom picklist using the same picklist ID, where it should be the custom filter.

Example:

Job Requisition Template has a field called "requiredTravel" (labeled: Travel Requirements) and it is uses a picklist called "travel", and this information needs to be made filterable in career site.
Filter01.jpg


A new filter is created (filter1), configured in provisioning to be called "Travel Requirements", and it will use the picklist called "travel".

Filter03.jpg

2. Search index issue

The search index hasn't been updated after a change in the Job Requisition template or search settings.

Resolution

1. Configuration issue

  1. Verify if the field being used in JRDM is the specific filter, and not another custom picklist with same label;
  2. Confirm if the filter is being filled when creating the Job Requisition, or any other field with similar name/label;
  3. Make sure the filter field is being used correctly (According to Implementation Guide).

Standard Field ID: filter1-15
Field Type: picklist
Special Function:

  • Can be made searchable on candi­date-facing career sites
  • If searchable, appears in other requisition search dialogue boxes, such as Forward Candidate to Requisition search
  • Should be configured as required, and use a picklist value of N/A or similar if clients want to be optional. Leaving this field unrequired can cause grey Application Error pop ups in unexpected places
  • Labels and picklist associations must be configured in Provisioning > Internal and External Applicant Status Settings
  • Should have a picklist defined in the XML even though the controlling picklist is set up in Provisioning.  This will produce a warning mes­sage upon XML upload but will not block upload. XML picklist definition is necessary for some token render­ing, report rendering and API inter­action
  • Supports cascading (parent-child) picklists up to six levels deep

*Keep in mind that, if multiple templates for Job Requisitions are being used, changes will have to be made in all of them;
**Also keep in mind that, those changes will take effect on newly created Job Requisitions; For older Job Requisitions, the information in this newly created filter must be entered on each one.

Following Example Above:

"Filter1" must be added in JRDM to replace the "requiredTravel" to be searchable.
Filter02.jpg

2. Search index issue

If filter configurations are correct, consider re-indexing for JOB_REQ. Please raise a ticket to support and provide required information so that they can review configurations and do re-index for you if needed.

  • Company id
  • Data center
  • Support access
  • Steps to reproduce the issue

See Also

2198169 - How do job filters work in a Career Site

Keywords

standard filter, recruiting, searchable, no results, career, site, recruiting, RCM, custom, filter1, internal, job , KBA , LOD-SF-RCM , Recruiting Management , Problem

Product

SAP SuccessFactors Recruiting all versions