Symptom
You may encounter the following issues related to translation tool within custom Fine Tune Activity:
- You have a custom solution with custom fine-tune activities that are relevant to be edited during the implementation of your system. You maintain one or more entries on the fine-tune activity and you have a requirement to maintain one or more translations for the entries. You tried to use the translation tool by clicking on button Translate, but when the tool opens, it does not show any record to be translated even if you change the source and target language to every possible combination.
- You click the button Translate; however, the Model Dialog where you configure source and target language does not open.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SAP Cloud for Customer.
- SAP Business ByDesign.
- SAP Cloud Application Studio.
Reproducing the Issue
To reproduce scenario #1, please follow the below steps:
- Go to Work Center Business Configuration.
- Go to Work Center View Implementation Project.
- Click button Open Activity List.
- Search for BAC_NAME (BAC_NAME stands for the name that you give for the BAC element created for the custom solution) and open it.
- Open the fine tune activity ACTIVITY_NAME (ACTIVITY_NAME stands for the activity name that you provided and created for the Business Configuration View).
- Click button Add to add new entries on the table and click button Save when done.
- Click button Translate.
- Set Source Language to the main language used on the system and set Target Language to the language that you want to translate the entries.
No entries are listed or showed. You could not add any translation for your entries.
To reproduce the scenario #2, please follow the below steps:
- Go to work center Business Configuration.
- Access the Implementation Project work center view.
- Click Open Activity List.
- Search for BAC_NAME and open it.
- Open the fine tune activity ACTIVITY_NAME.
- Click the Add button to add new entries on the table and click button Save when done.
- Click the Translate button.
Action does not execute and Model Dialog to configure your translation does not work.
Cause
Cause of scenario #1 is as follows:
The Translate tool used in custom fine-tuning activities only works if there is a field with Field Type set as Description. Only the content of Description fields will be available for translation. You need to check on your Business Configuration Object if there is any field with this Field Type; if not, the Translate tool will not show any entry to be translated.
Cause of scenario #2 is as follows:
Since 1811 release, property Lazy Load which can be found in the BC view screen within UI designer is causing issues with the Translate button of custom fine-tuning activities. One of the symptoms could be inability to open the Translate Model Dialog on custom BC View screens. By default, this property is set by PDI to True as seen in below screenshot. This issue is being addressed in future releases, but for now, to change UI behavior you need to manually adjust the property of this field to False.
NOTE: Lazy Load is a property which determines how much data is loaded when screen is opened. Let's assume we have an Opportunity with three facets: two of them have Lazy Load set to False, but one of them have this property set to True. This means that when you open this specific Opportunity TI, data will only load for the Embedded Component where Lazy Load is set to True. Otherwise, it will load when other facets are open. This is one of possible ways to enhance the performance of the UI.
Resolution
Depending on scenario #1:
-
Log on to SDK.
- Open solution YABC12345_ (YABC12345_ stands for your custom solution ID).
- Open Business Configuration Object file related to the custom fine tune activity with Translate issue.
- Go to the tab Fields.
- In the table, look on the column Field Type if there is any field set as Description.
- If not, add a field with Field Type equal to Description, or edit the Field Type of an existing field to Description.
- If yes, open an SAP incident requiring more analysis on this issue.
Depending on scenario #2:
- Open affected BC View screen in the UI Designer.
- Navigate to tab Controller.
- Open folder Model Dialogs and choose BusinessConfigurationGenericTranslate_MD.
- Change the behavior of property Lazy Load to False (this is also explained in the above screenshot).
Keywords
Fine Tune; Custom; BCO; BCC; BAC; Translate; Entry; Entries; Activity; lazy load, translate button not working , KBA , translate , not working , custom solution , AP-RC-BDS-TRANSL , ByDesign Studio Translation , Problem