SAP Knowledge Base Article - Public

2641879 - Save Without Mandatory Fields For New Contact Has Inconsistent Error Markings For Last Name

Symptom

When you save a new contact without adding the Last Name, the

Environment

SAP Hybris Cloud for Customer

Reproducing the Issue

  1. Go to the Customers work centre.
  2. Go to the Contacts view.
  3. Click New.
  4. Do not enter mandatory data.
  5. Click Save.

Result: while the field Last Name is mandatory, it does not get highlighted with red surrounding in the same way as other fields marked mandatory through key user choice.

Highlight on mandatory fields_last name.jpg

Cause

This is unfortunately currently a limitation in the C4C business partner UI's. Fields which are marked by key users via KUT/flexibility as mandatory are checked by UI runtime in a different way and therefore they get a red border.

Resolution

A software correction for this inconsistency is part of our backlog and is planned to be resolved in one of the next releases. Please note that it is not possible for our Support Team to provide you additional information regarding the availability of this feature in a future release.

Keywords

Contact, red, Last Name, New, Save, Mandatory, Without, Pflichtfelder bei Anlage Ansprechpartner , KBA , LOD-CRM-CON , Contact , Bug Filed

Product

SAP Cloud for Customer add-ins 1805