SAP Knowledge Base Article - Public

2641997 - A Direct Message From Twitter Does Not Re-Open an Existing Ticket

Symptom

An incoming Direct Message does not re-open a Completed Ticket.

The Direct Message creates a new Ticket instead of being added to the existing one.

Environment

SAP Hybris Cloud for Customer

Reproducing the Issue

  1. Ticket ABC (ABC represents the Ticket ID) gets created Via Direct Message from Twitter by Customer XYZ (XYZ represents the Individual Customer).
  2. Go to the Service work center.
  3. Select the Tickets view.
  4. Open Ticket ABC.
  5. Reply with a Direct Message.
  6. Change the Status of the Ticket to Completed.
  7. Customer XYZ replies with another Direct Message.

This Direct Message opens a new Ticket instead of re-opening the existing Ticket.

Cause

For Twitter Channels, Direct Messages always create a new Ticket.

The Direct Message will only be added to an existing Ticket, if the Ticket is still open and not Completed.

Resolution

This is the expected system behaviour in SAP Hybris Cloud for Customer.

Keywords

Twitter Direct Message reopen re-open added extisting ticket create new , KBA , LOD-CRM-SRP , Service Request Processing , Problem

Product

SAP Cloud for Customer add-ins 1805