Symptom
Contact details are not visible within the Business Partner TI.
Environment
SAP Hybris Cloud for Customer.
Reproducing the Issue
-
Open the Customers work center.
- Go to the Contacts view.
- Open the Contact DEF (DEF represents the Contact ID).
- Go to the Relationships tab.
- Here you can see the Business Partner ABC is maintained as the main contact (ABC represents the Business Partner ID).
- This Buisness Partner has the Relationship Type Is Contact Person For.
- Open the Business Partner ABC.
- You can see in the header information that the Contact DEF is maintained as the Primary Contact.
- Open the Contact DEF.
- The Contact opens but no details are visible.
11. Further more if you open the Contact tab of the Business Partner ABC, the Contact DEF is not visible.
Cause
The main Contact DEF is assigned the Relationship type Contact Person and not Partner Contact. You will not find that Partner Contact in the Partner Contact OWL. This also explains why you won't find the Contact DEF in the Contact tab of the Business Partner ABC. It also explains why the Main Contact navigation in the Partner TI header is not working as expected.
Resolution
To avoid such behaviour, it is advised to maintain only Partner Contacts to Business Partners and not regular Contacts, otherwise this leads to unexpected system behaviour.
Keywords
KBA , contact , business partner , relationships tab. , visible , LOD-CRM-PRN , Partner , Problem